ロリポップ!レンタルサーバー

よくある質問

よくある質問と回答集です。サービスご利用の参考にしてください。

1

PHPバージョン変更について気をつけることはありますか?

■PHPバージョン変更前の動作確認について
━━━━━━━━━━━━━━━━━━━━━━
2019年12月まではPHPバージョンをPHP5.6(CGI版)に戻すことができますので、PHP7.3(CGI版)とPHP5.6(CGI版)どちらでも動作をお試しいただく事ができます。
PHP5.6(CGI版)のご利用についてとPHPバージョンの変更については下記ページをご確認ください。

 ○PHP5.6(CGI版)のご利用について
 https://lolipop.jp/info/news/6446/

 ○PHPバージョンの変更
 https://lolipop.jp/manual/user/php-setting/

※2019年12月以降はPHP5.6(CGI版)を選択する事ができなくなりますのでご注意ください

■PHPバージョン変更前に何かやることはありますか?
━━━━━━━━━━━━━━━━━━━━━━
PHPはバージョンが変わると、機能向上のために機能の削除や仕様変更が行われることが多く、プログラムによっては正常に動作しない事があります。
その為、利用するプログラムの作成元に推奨動作環境などの情報から、対応バージョンをご確認ください。

■PHPをバージョン変更後、データーベース接続確立エラーが表示されました
━━━━━━━━━━━━━━━━━━━━━━
「データベース接続確立エラー」が表示される場合、データベースのパスワード形式が影響している可能性があります。
対応方法についてはPHP7.1以上を利用のドメインで簡単インストール、サイト表示ができませんをご確認ください。

■PHPをバージョン変更後、 WordPressが表示できなくなった
━━━━━━━━━━━━━━━━━━━━━━
PHPのバージョン変更後、WordPressに関するエラーについて恐れ入りますがWordPress本体や各プラグインは弊社にて開発を行っていないため、ご利用のWordPress本体を含めテーマやプラグインが変更後のPHPのバージョンに対応しているか配布元に対応バージョンをご確認ください。