ロリポップ!レンタルサーバー

お知らせ

『ロリポップ!』からのお知らせです。

2019年10月から『PHP7.3』を提供開始いたします

この度、ロリポップ!全サーバーを対象にPHP7.3のCGI版とモジュール版を提供開始いたします。

最新のPHPバージョンヘアップデートすることにより、下記のメリットがあります。

【PHPの処理速度の向上】
PHPはバージョンが上がるごとに改良が加えられており、新しいバージョンほど効率的に動作するようになっています。
そのため、PHP7.3(モジュール版)にアップグレードすると、以前のバージョンに比べてパフォーマンスが向上します。

 ※PHP7.3(CGI版)ではWEBサイトの表示速度に変化が出ない可能性があります。

【Webサイトのセキュリティの向上】
PHPにはサポート期間が存在しており、サポートが終了した古いバージョンにはセキュリティ対策が行われません。
最新からいくつかのサポートされているバージョンは、セキュリティ対策が行われておりますため、PHPのアップデートはWEBサイトの安全性にとって非常に重要です。

なお、PHP7.3のリリース内容とスケジュールにつきましては、以下をご参照ください。

■10月のリリース
 ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
【PHP7.3(CGI版)を追加】

▽対象 (ハイスピードプランは対象外)
全てのサーバー


11月と12月にリリースされるPHP7.3(モジュール版)をご利用いただく前に、サイト表示、プログラムの動作に問題がないか予めPHP7.3(CGI版)環境でご確認いただきますようお願いいたします。

■11月のリリース
 ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
【PHP5.6(モジュール版)の提供終了、PHP7.3(モジュール版)の提供開始】

▽対象 (エコノミープラン・ライトプラン・ハイスピードプランは対象外)
users316 〜 318
users382 〜 390
users401 〜 421
users451 〜 499

※ PHP7.3(CGI版)をご利用いただいている場合、自動的にPHP7.3(モジュール版)へ変更されます。
※ PHP5.6(モジュール版)をご利用いただいている場合、自動的にPHP5.6(CGI版)へ変更されます。
※ リリース後、PHP5.6(モジュール版)は利用できなくなります。

■12月のリリース
 ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
【PHP5.6(CGI版)の新規利用停止】

▽対象 (ハイスピードプランは対象外)
全てのサーバー

※ PHP5.6(CGI版)ご利用中の場合、引き続きご利用いただけますが、ユーザー専用ページにて新たにPHP5.6(CGI版)の選択ができなくなります。


【PHP7.1(モジュール版)の提供終了、PHP7.3(モジュール版)の提供開始】

▽対象 (エコノミープラン・ライトプラン・ハイスピードプランは対象外)
users315
users320
users422 〜 450
users701 〜 714

※ 新規お申込みのサーバーもPHP7.3(モジュール版)に対応します。
※ PHP7.1(モジュール版)とPHP7.3(CGI版)をご利用いただいている場合、自動的に7.3(モジュール版)へ変更されます。
※ リリース後、PHP7.1(モジュール版)は利用できなくなります。


■PHP のアップデート早見表
 ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
※1 スタンダードプランとエンタープライズプランが対象です。

現在 10月リリース 11月リリース 12月リリース
ハイスピードプラン 対応済み 対応済み 対応済み 対応済み
エコノミープラン
ライトプラン
7.1(CGI版)
5.6(CGI版)
7.3(CGI版)
7.1(CGI版)
5.6(CGI版)
- 7.3(CGI版)
7.1(CGI版)
-
users316 〜 318
users382 〜 390
users401 〜 421
users451 〜 499
※1
5.6(モジュール版)
7.1(CGI版)
5.6(CGI版)
5.6(モジュール版)
7.3(CGI版)
7.1(CGI版)
5.6(CGI版)
7.3(モジュール版)
7.3(CGI版)
7.1(CGI版)
5.6(CGI版)
7.3(モジュール版)
7.3(CGI版)
7.1(CGI版)
-
users315
users320
users422 〜 450
users701 〜 714
※1
7.1(モジュール版)
7.1(CGI版)
5.6(CGI版)
7.1(モジュール版)
7.3(CGI版)
7.1(CGI版)
5.6(CGI版)
- 7.3(モジュール版)
7.3(CGI版)
7.1(CGI版)
-
新規お申込みサーバー
※1
7.1(モジュール版)
7.1(CGI版)
5.6(CGI版)
7.1(モジュール版)
7.3(CGI版)
7.1(CGI版)
5.6(CGI版)
- 7.3(モジュール版)
7.3(CGI版)
7.1(CGI版)
-


■PHPの切り替えについて
 ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
PHPバージョンの切り替え後、正常に動作しない可能性がありますため、ホームページの表示・動作確認をおすすめいたします。

・ユーザー専用ページでのバージョン切替方法はPHP設定をご覧ください。


PHP7.3の詳細な提供日程等に関しましては、本インフォメーションにて追ってご案内させていただきます。

(2019/09/11 14:04 更新)


【2019/10/10 13:30 追記】

2019年10月10日(木)にロリポップ!全サーバーを対象にPHP7.3(CGI版)を提供開始いたしました。

▽ 『PHP7.3(CGI版)』提供開始いたしました!
https://lolipop.jp/info/news/6430/

PHPのバージョン変更方法はPHP設定をご参照いただき、PHP7.3(CGI版)への変更をお試しいただけますと幸いです。

また、スタンダードプランとエンタープライズプランをご利用のお客様につきましては、11月と12月にPHP7.3(モジュール版)のリリースを予定しております。
PHP7.3(モジュール版)をご利用いただく前に、サイト表示、プログラムの動作に問題がないか予めPHP7.3(CGI版)環境でご確認いただきますようお願いいたします。

PHP7.3(モジュール版)のリリースの詳細な日程につきましては、本インフォメーションにて追ってご案内させていただきます。



【2019/11/05 10:28 追記】

2019年11月06日(木)より、ロリポップ!一部サーバーを対象にPHP7.3(モジュール版)を順次提供開始いたします。

11月のPHP7.3(モジュール版)提供対象サーバーとリリース日程につきましては、下記をご参照いただきますようお願いいたします。

日程 対象サーバ
11月6日(水) users316-318・users382~390
11月12日(火) users451・users457~475
11月19日(火) users476~499
11月26日(火) users401~421


PHPのバージョン変更方法はPHP設定をご参照いただき、PHP7.3(モジュール版)への変更をお試しいただけますと幸いです。

また、12月にもPHP7.3(モジュール版)の順次リリースとPHP5.6(CGI版)の新規利用停止を予定しております。

お手数ではございますが、あらかじめPHP7.3(CGI版)での動作確認や、PHP7.3(モジュール版)への変更をご検討いただけますと幸いです。

なお、12月のPHP7.3(モジュール版)のリリースとPHP5.6(CGI版)の新規利用停止の詳細な日程につきましては、本インフォメーションにて追ってご案内させていただきます。

このエントリーをはてなブックマークに追加