ロリポップ!レンタルサーバー
[6/30まで]契約期間延長キャンペーン中!ブログ・ホームページを始めよう 詳細を見る 告知を閉じる
ご利用のブラウザ(Internet Explorer)のサポートは2021年8月31日で終了します。
早めのブラウザの切り替えをお願いいたします。詳しくはこちら

このたび、ロリポップでは、全プランにて『PHP8.2』の提供を開始いたしました。
『PHP8.2』には、「読み取り専用クラス」「"Random" 拡張モジュール」「動的なプロパティの非推奨化」といった新機能が追加されました。

■内容
 ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
・サーバー番号がecoxxx、litxxx、stdxxx、ent7xx、ent8xxのサーバーへ『PHP8.2 CGI版』を提供開始
・サーバー番号がspdxxx、ent0xx、ent1xxのサーバーへ『PHP8.2 LiteSpeed版』を提供開始
※ご利用のPHPバージョンが自動で切り替わることはございません

■簡単インストール機能について
 ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
下記のCMSはPHP8系でのインストールに対応しておりません。簡単インストールをご利用いただく場合は、PHP7.4をご利用ください。
・baserCMS
・EC-CUBE

【PHPの処理速度の向上】
PHPはバージョンが上がるごとに改良が加えられており、新しいバージョンほど効率的に動作するようになっています。

PHP8.2の詳しい情報は公式サイトをご確認ください。

▽PHP 8.2 リリースについて - PHP公式サイト
https://www.php.net/releases/8.2/ja.php

【Webサイトのセキュリティの向上】
PHPにはサポート期間があり、サポートが終了した古いバージョンにはセキュリティ対策が行われません。

PHP7.4以前のバージョンは、公式のサポート期間がすでに終了しています。
この機会にぜひPHPのアップデートをご検討ください。

■Wordpressをご利用のみなさま
 ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
公式でサポートが終了した古いバージョンはサイトを脆弱性にさらす恐れがあります。
そのため、WordPressサイトは最新バージョンへアップデートいただき、PHP8系での運用を推奨します。

■PHPの切り替えについて
 ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
ロリポップでは、ユーザー専用ページよりPHPのバージョンの切り替えが可能です。
詳しくはこちらのマニュアルをご覧ください。

▽PHP設定について
https://lolipop.jp/manual/user/php-setting/

※PHPバージョンの切り替え後、ホームページが正常に動作しない可能性がございます。
切り替え時には、事前にバックアップを取得し、ホームページの表示・動作確認を行ってください。

このエントリーをはてなブックマークに追加